Tuesday, May 2, 2017

CPU lag spikes while moving mouse

So recently i faced with strange problem: While moving mouse i have seen noticeable lags spikes like wrapping for a several seconds and lag stops after it and mouse starts to move smoothly again. Doesn't matters what places - gaming / desktop or even bios.

My PC specs:

Windows 10
Nvidia GTX 770
Intel I5-2400 @ 3,1 Ghz
DDR3 8 GB ram
Asus mother board p8h61-m le r2.0
bios 1408

It felt like it was a virus / trojan or other bad program which uses CPU / HDD or other PC resources.

Preparation 

First thing what i did is checked Task manager. Than i have continued and monitored several hours in resource monitor. But nothing was noticed in cpu / memory / disk neither in network tab.

Secondly I have installed few free or trial versions of anti-viruses and other monitoring applications:

  • Kaspersky ( https://www.kaspersky.com/downloads/thank-you/antivirus-free-trial ) install and made full scan
  • Malwarebytes ( https://www.malwarebytes.com/business/ ) install and made full scan
  • Bitdefender ( https://www.bitdefender.com/solutions/free.html ) made full scan
  • CCleaner ( https://www.piriform.com/ccleaner/download ) full scan
But nothing was found.

Hard drive check

Next i have checked hard drive for bad sectors. Made other scans with programs like
  • LatencyMon ( http://www.resplendence.com/latencymon )

Advanced task manager

For more advanced tasks monitoring i have installed programs like:
  • Open hardware monitor ( http://openhardwaremonitor.org/ )
  • Security task manager ( https://www.neuber.com/taskmanager/ )
But still no results and bad process was fount there. 

Notices


After multiple check noticed:
  • Lag spikes was noticed even in BIOS
  • Sometimes lags disappear but after some use of PC the lags appeared back.
Other tries was made to prevent lags:
  • Disable cortana
  • Performance windows 10 optimization ( recommended youtube video with full steb by step instuction how to clean and disable unusefull programs/services and gadgets https://www.youtube.com/watch?v=DwiHog2leMM ) 
  • Disabling Realtek HD drivers
  • Disabling Nvidia sound drivers
  • Try to update bios ( but i had latest version )


Ask profesionals for help

Coworker/Friend of mine suggested to disconnect GPU.

After i have disconnected GPU i have noticed some improvement, but not for long... after few moments lags was noticed again. 

Logitech m185


Finally suggestion was to try disconnect used USB port devices and look if something is interrupting. And after i have changed bluetooth mouse usb plugin i came up with idea that maybe my mouse is broken ( because of rage gaming ). So what i did i changed mouse with same model - logitech m185 ( best mouse in the world. if you want one buy it here ) my wifes one. 
And miracle happened. It worked perfectly! No lags, no spikes nothing, but smooth movements. 

Finally 

And finally i came up with idea to try changing battery on my mouse. And guess what...  It started to work perfectly again

Problem that i didn't though about battery at first time was because that when my battery dies mouse stops working immediately, but this time it didn't happen that way.


 

2 comments:

  1. Heya i'm for the first time here. I found this board and I find It truly useful & it helped me
    out much. I hope to provide something back and help others such as you aided me.

    ReplyDelete